Monday 12 March 2007

SMF manifest for buildbot

As I mentioned in a previous post, I use buildbot for testing my Solaris installations. I'll be writing more about that in a future article. Until then here is a Solaris 10 SMF manifest that I've developed for starting up a buildbot master or slave. By default it creates one instance called default with a configuration path of /home/buildbot/master.

Before using this manifest you'll need to create your buildbot master or slave directories yourself using buildbot create-master or buildbot create-slave.

To change the path run:
# svccfg -s svc:/site/application/buildbot:default setprop buildbot/config="/path/to/buildbot/dir"

Then enable the service:
# svcadm enable svc:/site/application/buildbot:default

With this manifest you can run as many buildbot masters and slaves as your system can handle.

To add another instance run:
# svccfg -s svc:/site/application/buildbot add instance
# svccfg -s svc:/site/application/buildbot:instance addpg buildbot application
# svccfg -s svc:/site/application/buildbot:instance setprop buildbot/config="/path/to/instance"

Now enable the new buildbot instance:
# svcadm enable svc:/site/application/buildbot:instance


Update: Added the PATH environment variable to the manifest.

4 comments:

ggruendgens said...

I guess you misspelled the domain name in the link to buildbot: http://buildbot.sourceforce.net/ (notice the second 'c')

Matthew Flanagan said...

Thanks for picking that up. I've fixed the link.

David Abrahams said...

For Solaris n00bs like me, it would help to tell us how to install this manifest.

pfexec svccfg import buildbot.xml

?

David Abrahams said...

Also, for additional instances, you need

svccfg -s svc:/site/application/buildbot:instance setprop buildbot/config=astring: "/path/to/instance"

(I think) Note the astring: